teleinfo et Domoticz sur PC

Accueil Forums Modem Téléinfo (USB, XBEE…) teleinfo et Domoticz sur PC

Ce sujet a 54 réponses, 5 participants et a été mis à jour par  Nicolas44, il y a 1 mois et 2 semaines.

15 sujets de 1 à 15 (sur un total de 55)
  • Auteur
    Messages
  • #6806

    efer06
    Participant

    Bonjour,

    j’ai branché mon teleinfo mode standard linky sur mon pc . avec des outils comme « teleinfo test » ou  » teleinfo 2 compteurs  » je vois la trame aucun problème .

    Seulement sur Domoticz 4.9700 impossible de configurer . dans hardware le serial port est fixe sur  » COM3″ , impossible de suivre le tuto du site http://www.cartelectronic.fr/blog/?p=478

    Sur LOG j’ai : error opening serial port , even with charsize:8

    Merci de votre aide

    #6807

    nicolas_cartelec
    Admin bbPress

    Domoticz n’intègre pas encore le mode STANDARD des Linky.

    Je pose la question à un collègue.

    #8950

    xavier188
    Participant

    bonjour, j’ai le meme probleme. je suis sous windows. J’ai ce message également : <span class= »logerror »>Error opening serial port, even with CharSize:8 !</span>

    dans le log

    je suis en 1200 bauds et c’est aussi le port COM3

    Mais je suis en mode historique.

    #8951

    nicolas_cartelec
    Admin bbPress

    Charsize doit être à 7.

    Quel abonnement avez vous ?

    #8952

    xavier188
    Participant

    je suis en HP HC en mode historique en linky. Marche impec avec TELEINFO 2 compteurs.

    charsize est ou ?

    #8953

    xavier188
    Participant

    Bon,

    je viens de changer de navigateur et j’ai redemarré le PC. j’ai mis la vers 4.107.17 de Domoticz.

    J’ai pu enregistrer le Materiel : type Teleinfo EDF / com 3 / 1200b son nom est edf

    dans le log j’ai =

    (edf) CRC checks will be performed on incoming data

    donc ca lit. On progresse.

    Dans dispositif j’ai la page qui bloque sur loading…….

    une idée ?

    • Cette réponse a été modifiée le il y a 2 mois par  xavier188.
    • Cette réponse a été modifiée le il y a 2 mois par  xavier188.
    #8958

    cdlog2
    Participant

    Pour info, le port de Com recevant les trames de la téléinfo en mode historique doit être configuré :  bauds:1200 parité:even(pair) data-bits:7 stop-bit:1

    Votre erreur de  CharSize:8 est due au fait que le port de Com utilisé est configuré en 8 bits au lieu de 7 bits.

    Il faut configurer votre port de Com en 7 bits ( CharSize = data-bits = taille des caractères = 7 bits).

    #8959

    xavier188
    Participant

    j’ai suivi cette info et j’ai toujours la console qui charge un dispositif et ca bloque.

    J’ai le led du Teleinfo qui ne s’allume pas

    • Cette réponse a été modifiée le il y a 2 mois par  xavier188.
    #8961

    nicolas_cartelec
    Admin bbPress

    C’est quel port com le modem ?

    si vous arrivez pas à mettre le bon port cela vient de là !

    #8962

    xavier188
    Participant

    non je n’ai qu’un port émulé, c’est le 3, comme pour le soft de teleinfo. Je ne me suis pas trompé. Je précise qu’a chaque essai, je redémarre pour libérer le port.

    • Cette réponse a été modifiée le il y a 2 mois par  xavier188.
    #8964

    nicolas_cartelec
    Admin bbPress

    Quel abonnement avez vous ?

    Je sais pas si domotic’z lit tout les abonnements historiques !

    #8965

    xavier188
    Participant

    HC/ HP monophasé en historique

    #8966

    cdlog2
    Participant

    Peut être une piste ? Mais je n’utilise pas Domoticz

    Domoticz sous Linux, il semble nécessaire de configurer le Port COM physique ( /dev/ttyUSBx) aux bons paramètres de transmission du modem Téléinfo via la console. Exemple pour le mode historique : sudo stty -F /dev/ttyUSBxx 1200 sane evenp parenb cs7 -crtscts

    Cela sous entend, peut être ?, que Domoticz ne configure pas de lui même le Port Com du modem aux bonnes valeurs ?

    Concernant Domoticz sous Windows, faut t’il configurer, de la même manière, les paramètres du Port de Com Utilisé manuellement ?
    Depuis le gestionnaire de périphérique Clic droit sur le Port de Com et paramètres ! bauds:1200  parité:pair  data-bits:7  stop-bit:1

    Cdt

    #8967

    xavier188
    Participant

    Domoticz sous Windows y a pas vraiment de choix possibles pour le type de matériel: c’est forcement « Teleinfo EDF »

    le port proposé est forcement le « COM3

    donc j’ai essayé de faire le paramètre sous Windows en ce qui concerne le port com, dans le gestionnaire de périphériques.

    baud 1200

    parité pair

    bits de données 7

    bits d’arret 1

     

    Mais j’ai également le message

     

    (edf) CRC checks will be performed on incoming data

    on dirait que sa lit

    et quand je vais dans « dispositif » j’ai le message loading……… rien ne vient. Et surtout la led verte du téléinfo ne s’allume pas

     

    C’est bizarre quand même. Je précise que si je libère le port com (en redémarrant) sans relancer Domoticz, Teleinfo 2 compteur, sous Windows, marche impec ! La led est verte et bien brillante

    • Cette réponse a été modifiée le il y a 2 mois par  xavier188.
    #8969

    cdlog2
    Participant

    Il n’y a qu’une explication, Domoticz ne configure pas le driver du Port de Com aux bons paramètres comme le fait le logiciel Teleinfo 2 Compteur.

    Car sous Linux cela ne fonctionne pas non plus si vous ne forcez pas les bons params via la console.

    J’ai recherché sur la toile, j’ai trouvé un seul cas comme vous qui à le même problème avec le même message …. loading et rien ne bouge. Par contre il n’a pas eu de solus fourni.

    Peut être une bonne âme sur ce Blog, utilisant Domoticz sous Windows et ayant rencontré et solutionné le problème pourrait vous les communiquer.

    Il doit y avoir un Script spécifique pour le type « Teleinfo EDF » dans Domoticz. Il faudrait trouver ce Script et voir comment il gère le driver du Port de Com mis en paramètre.

     

    Cdt

     

     

     

15 sujets de 1 à 15 (sur un total de 55)

Vous devez être connecté pour répondre à ce sujet.